文章显示出问题了!

tomsss   ·   发表于 2017-9-1   ·   BUG建议

我发了两篇帖子,分别在两个板块,帖子内容也不一样。然后我在主页打开两篇帖子,内容都一摸一样都是第一篇的内容,两篇帖子的网址也都一样!然后我又发了几篇也是这种情况,这是怎么回事,怎么解决?

16 Reply   |  Until 2017-9-6 | 4894 View

tomsss
发表于 2017-9-1

评论列表

  • 加载数据中...

编写评论内容

admin
发表于 2017-9-2

截图  thread表结构 

评论列表

  • 加载数据中...

编写评论内容

nilkkk
发表于 2017-9-2

应该是和我原来一样,没有帖子ID,没有写入数据表

评论列表

  • 加载数据中...

编写评论内容

tomsss
发表于 2017-9-2


@admin  

评论列表

  • 加载数据中...

编写评论内容

tomsss
发表于 2017-9-2


@nilkkk  对没有ID


评论列表

  • 加载数据中...

编写评论内容

tomsss
发表于 2017-9-2

@admin  有点迷糊

评论列表

  • 加载数据中...

编写评论内容

admin
发表于 2017-9-2

表主键没有AUTO_INCREMENT 

安装的时候没有正常写入

按照下面的方法手动修复一下 

用phpmyadmin进入论坛数据库 再进入SQL选项执行以下内容

--
    -- 在导出的表使用AUTO_INCREMENT
    --

    --
    -- 使用表AUTO_INCREMENT `hy_chat`
    --
    ALTER TABLE `hy_chat`
      MODIFY `id` int(10) UNSIGNED NOT NULL AUTO_INCREMENT, AUTO_INCREMENT=1;
    --
    -- 使用表AUTO_INCREMENT `hy_file`
    --
    ALTER TABLE `hy_file`
      MODIFY `id` int(10) UNSIGNED NOT NULL AUTO_INCREMENT COMMENT '附件ID', AUTO_INCREMENT=1;
    --
    -- 使用表AUTO_INCREMENT `hy_forum_group`
    --
    ALTER TABLE `hy_forum_group`
      MODIFY `id` int(10) UNSIGNED NOT NULL AUTO_INCREMENT, AUTO_INCREMENT=1;
    --
    -- 使用表AUTO_INCREMENT `hy_post`
    --
    ALTER TABLE `hy_post`
      MODIFY `pid` int(10) UNSIGNED NOT NULL AUTO_INCREMENT, AUTO_INCREMENT=1;
    --
    -- 使用表AUTO_INCREMENT `hy_thread`
    --
    ALTER TABLE `hy_thread`
      MODIFY `tid` int(10) UNSIGNED NOT NULL AUTO_INCREMENT, AUTO_INCREMENT=1;
    --
    -- 使用表AUTO_INCREMENT `hy_user`
    --
    ALTER TABLE `hy_user`
      MODIFY `uid` int(10) UNSIGNED NOT NULL AUTO_INCREMENT, AUTO_INCREMENT=2;


评论列表

  • 加载数据中...

编写评论内容

tomsss
发表于 2017-9-3


@admin  好的,谢谢

评论列表

  • 加载数据中...

编写评论内容

tomsss
发表于 2017-9-3


@admin  

刚回来弄了一下,这个是啥情况

评论列表

  • 加载数据中...

编写评论内容

admin
发表于 2017-9-3

--
    -- 在导出的表使用AUTO_INCREMENT
    --

  
    --
    -- 使用表AUTO_INCREMENT `hy_file`
    --
    ALTER TABLE `hy_file`
      MODIFY `id` int(10) UNSIGNED NOT NULL AUTO_INCREMENT COMMENT '附件ID', AUTO_INCREMENT=1;
    --
    -- 使用表AUTO_INCREMENT `hy_forum_group`
    --
    ALTER TABLE `hy_forum_group`
      MODIFY `id` int(10) UNSIGNED NOT NULL AUTO_INCREMENT, AUTO_INCREMENT=1;
    --
    -- 使用表AUTO_INCREMENT `hy_post`
    --
    ALTER TABLE `hy_post`
      MODIFY `pid` int(10) UNSIGNED NOT NULL AUTO_INCREMENT, AUTO_INCREMENT=1;
    --
    -- 使用表AUTO_INCREMENT `hy_thread`
    --
    ALTER TABLE `hy_thread`
      MODIFY `tid` int(10) UNSIGNED NOT NULL AUTO_INCREMENT, AUTO_INCREMENT=1;
    --
    -- 使用表AUTO_INCREMENT `hy_user`
    --
    ALTER TABLE `hy_user`
      MODIFY `uid` int(10) UNSIGNED NOT NULL AUTO_INCREMENT, AUTO_INCREMENT=2;


评论列表

  • 加载数据中...

编写评论内容

tomsss
发表于 2017-9-3


@admin  

我可能有毒

评论列表

  • 加载数据中...

编写评论内容

709011615
发表于 2017-9-5


@admin  同样的问题,新装的也一样,而且按照这个数据库执行,夜市错误

评论列表

  • 加载数据中...

编写评论内容

709011615
发表于 2017-9-6

 怎么解决

评论列表

  • 加载数据中...

编写评论内容

709011615
发表于 2017-9-6

 

@admin

 一直不对呀,怎么解决

评论列表

  • 加载数据中...

编写评论内容

admin
发表于 2017-9-6

  ALTER TABLE `hy_file`
      MODIFY `id` int(10) UNSIGNED NOT NULL AUTO_INCREMENT;
    --
    -- 使用表AUTO_INCREMENT `hy_forum_group`
    --
    ALTER TABLE `hy_forum_group`
      MODIFY `id` int(10) UNSIGNED NOT NULL AUTO_INCREMENT;
    --
    -- 使用表AUTO_INCREMENT `hy_post`
    --
    ALTER TABLE `hy_post`
      MODIFY `pid` int(10) UNSIGNED NOT NULL AUTO_INCREMENT;
    --
    -- 使用表AUTO_INCREMENT `hy_thread`
    --
    ALTER TABLE `hy_thread`
      MODIFY `tid` int(10) UNSIGNED NOT NULL AUTO_INCREMENT;
    --
    -- 使用表AUTO_INCREMENT `hy_user`
    --
    ALTER TABLE `hy_user`
      MODIFY `uid` int(10) UNSIGNED NOT NULL AUTO_INCREMENT;


评论列表

  • 加载数据中...

编写评论内容

709011615
发表于 2017-9-6

 

@admin

 是我的问题么?用了你刚发的还是这样

评论列表

  • 加载数据中...

编写评论内容
LoginCan Publish Content